I think it's a matter of programming style for those routines that are
not part of the interface to the python engine. Somewhere you have to
cast, and it is a question of semantics whether you do the check in the
caller or the callee. Here it looks like getlistsize() serves the dual
role of checking its argument *and* returning the size.
Of course most of the callers don't use this feature and you'll end up
with a redundant check. Either way, I think I would gravitate towards
Guido approach since I find it simpler and more elegant (casts are not
my favorite either), even if it means some redundant checks.
-Jaap-
-- Jaap Vermeulen +--------------------------+ | Sequent Computer Systems | Internet : jaap@sequent.com | Beaverton, Oregon | Uucp : ...uunet!sequent!jaap +--------------------------+